about summary refs log tree commit diff
path: root/users/grfn/owothia/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/grfn/owothia/default.nix')
-rw-r--r--users/grfn/owothia/default.nix10
1 files changed, 8 insertions, 2 deletions
diff --git a/users/grfn/owothia/default.nix b/users/grfn/owothia/default.nix
index e10098ed94..b70d0525c1 100644
--- a/users/grfn/owothia/default.nix
+++ b/users/grfn/owothia/default.nix
@@ -2,5 +2,11 @@
 , pkgs ? depot.third_party.nixpkgs
 , ... }:
 
-pkgs.haskellPackages.callCabal2nix "owothia"
-  (depot.third_party.gitignoreSource ./.) { }
+let
+  basePkg = pkgs.haskellPackages.callPackage ./pkg.nix { };
+in
+
+pkgs.haskell.lib.overrideSrc basePkg {
+  src = depot.third_party.gitignoreSource ./.;
+  version = "canon";
+}