about summary refs log tree commit diff
path: root/users/grfn/owothia/default.nix
diff options
context:
space:
mode:
authorsterni <sternenseemann@systemli.org>2021-04-10T21·30+0200
committersterni <sternenseemann@systemli.org>2021-04-13T10·34+0000
commit2f4ea13ca2a76641052216139cc6267ca959ae0d (patch)
treeba3de13e19de1abb848c9bb8284bc2ea0e172436 /users/grfn/owothia/default.nix
parenta0cfa097e040f082d448288ca8a3c99231484b03 (diff)
refactor(users/grfn): build all haskell packages without ifd r/2501
Since we need to override random to 1.2.0 globally for xanthous
(otherwise propagation causes two versions of random to be propagated
for xanthous) evaluating haskell related stuff using import from
derivation can be very expensive since utilities like hpack and
cabal2nix need to be built for that. This means that for every channel
bump we potentially need to do a world rebuild of haskellPackages first.

To solve this we check in the cabal2nix-generated nix expressions for
owothia and xanthous.

Change-Id: I8fff70b4b6c303d1920f8bcac53520a09999b206
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2921
Tested-by: BuildkiteCI
Reviewed-by: grfn <grfn@gws.fyi>
Reviewed-by: tazjin <mail@tazj.in>
Diffstat (limited to 'users/grfn/owothia/default.nix')
-rw-r--r--users/grfn/owothia/default.nix10
1 files changed, 8 insertions, 2 deletions
diff --git a/users/grfn/owothia/default.nix b/users/grfn/owothia/default.nix
index e10098ed94..b70d0525c1 100644
--- a/users/grfn/owothia/default.nix
+++ b/users/grfn/owothia/default.nix
@@ -2,5 +2,11 @@
 , pkgs ? depot.third_party.nixpkgs
 , ... }:
 
-pkgs.haskellPackages.callCabal2nix "owothia"
-  (depot.third_party.gitignoreSource ./.) { }
+let
+  basePkg = pkgs.haskellPackages.callPackage ./pkg.nix { };
+in
+
+pkgs.haskell.lib.overrideSrc basePkg {
+  src = depot.third_party.gitignoreSource ./.;
+  version = "canon";
+}