about summary refs log tree commit diff
path: root/users/glittershark/xanthous/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/glittershark/xanthous/default.nix')
-rw-r--r--users/glittershark/xanthous/default.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/users/glittershark/xanthous/default.nix b/users/glittershark/xanthous/default.nix
index be8957f9f6..4af535a34d 100644
--- a/users/glittershark/xanthous/default.nix
+++ b/users/glittershark/xanthous/default.nix
@@ -1,11 +1,11 @@
 { nixpkgs ? import ./nixpkgs.nix {}
 , pkgs ? nixpkgs.pkgs
+, lib ? nixpkgs.lib
 , compiler ? "ghc865"
 , failOnWarnings ? false
 , ...
 }:
 let
-  inherit (nixpkgs) pkgs lib;
   inherit (lib) id;
   inherit (pkgs) fetchurl;
   all-hies = import (fetchTarball {
@@ -16,6 +16,6 @@ let
   xanthous =
     (if failOnWarnings then pkgs.haskell.lib.failOnAllWarnings else id)
       ((pkgs.haskellPackages
-      .extend (import ./haskell-overlay.nix { inherit nixpkgs; })
-    ).callPackage (import ./pkg.nix { inherit nixpkgs; }) {}); in
+      .extend (import ./haskell-overlay.nix { inherit pkgs; })
+    ).callPackage (import ./pkg.nix { inherit pkgs; }) {}); in
 xanthous // { inherit hie; }