about summary refs log tree commit diff
path: root/users/glittershark/xanthous/default.nix
diff options
context:
space:
mode:
authorGriffin Smith <grfn@gws.fyi>2020-06-29T00·33-0400
committerglittershark <grfn@gws.fyi>2020-06-29T00·38+0000
commit48cc610fa4681e4a423f47c5a9a19bf8ebe05821 (patch)
tree4a6f2e16636798f0ff714199a6793d485f3b5b01 /users/glittershark/xanthous/default.nix
parent93d1ab7a549143bb9f2e251409de3ac8282da828 (diff)
fix(xan): Build without nixpkgs in NIX_PATH r/1118
CI doesn't have a nixpkgs channel (obvs), and we want to be able to
build from the depot tree, so reorder some stuff so we never depend on
nixpkgs

Change-Id: I99b513a3d7bcd64b6d167335856651e0ca66e33b
Reviewed-on: https://cl.tvl.fyi/c/depot/+/734
Diffstat (limited to 'users/glittershark/xanthous/default.nix')
-rw-r--r--users/glittershark/xanthous/default.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/users/glittershark/xanthous/default.nix b/users/glittershark/xanthous/default.nix
index be8957f9f6..4af535a34d 100644
--- a/users/glittershark/xanthous/default.nix
+++ b/users/glittershark/xanthous/default.nix
@@ -1,11 +1,11 @@
 { nixpkgs ? import ./nixpkgs.nix {}
 , pkgs ? nixpkgs.pkgs
+, lib ? nixpkgs.lib
 , compiler ? "ghc865"
 , failOnWarnings ? false
 , ...
 }:
 let
-  inherit (nixpkgs) pkgs lib;
   inherit (lib) id;
   inherit (pkgs) fetchurl;
   all-hies = import (fetchTarball {
@@ -16,6 +16,6 @@ let
   xanthous =
     (if failOnWarnings then pkgs.haskell.lib.failOnAllWarnings else id)
       ((pkgs.haskellPackages
-      .extend (import ./haskell-overlay.nix { inherit nixpkgs; })
-    ).callPackage (import ./pkg.nix { inherit nixpkgs; }) {}); in
+      .extend (import ./haskell-overlay.nix { inherit pkgs; })
+    ).callPackage (import ./pkg.nix { inherit pkgs; }) {}); in
 xanthous // { inherit hie; }