about summary refs log tree commit diff
path: root/tvix/nix_cli/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tvix/nix_cli/shell.nix')
-rw-r--r--tvix/nix_cli/shell.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/tvix/nix_cli/shell.nix b/tvix/nix_cli/shell.nix
new file mode 100644
index 0000000000..f57019cd94
--- /dev/null
+++ b/tvix/nix_cli/shell.nix
@@ -0,0 +1,11 @@
+let
+  depot = (import ./.. { });
+  pkgs = depot.third_party.nixpkgs;
+
+in
+pkgs.mkShell {
+  buildInputs = [
+    pkgs.rustup
+    pkgs.rust-analyzer
+  ];
+}