about summary refs log tree commit diff
path: root/tvix/nix_cli/shell.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2022-08-11T16·10+0300
committertazjin <tazjin@tvl.su>2022-08-12T15·58+0000
commit31443d21eed5986d8b2968951e3e38283008b892 (patch)
tree5d38ef81679b6fe73d7b5f52e9a0cee6e9707071 /tvix/nix_cli/shell.nix
parent3ed45caad13bbe3133280d0934d9f0abd07a8c62 (diff)
chore(tvix): move nix-store CLI scaffolding to subfolder r/4419
For some reason a top-level Rust project ended up in this location,
which is incompatible with the actual project structure that's being
prepared for merge right now.

Change-Id: I9d919ad72fc7e4e4d8cbb9899e7f8d90fa7ca87a
Reviewed-on: https://cl.tvl.fyi/c/depot/+/6060
Tested-by: BuildkiteCI
Reviewed-by: flokli <flokli@flokli.de>
Autosubmit: tazjin <tazjin@tvl.su>
Diffstat (limited to 'tvix/nix_cli/shell.nix')
-rw-r--r--tvix/nix_cli/shell.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/tvix/nix_cli/shell.nix b/tvix/nix_cli/shell.nix
new file mode 100644
index 0000000000..f57019cd94
--- /dev/null
+++ b/tvix/nix_cli/shell.nix
@@ -0,0 +1,11 @@
+let
+  depot = (import ./.. { });
+  pkgs = depot.third_party.nixpkgs;
+
+in
+pkgs.mkShell {
+  buildInputs = [
+    pkgs.rustup
+    pkgs.rust-analyzer
+  ];
+}