about summary refs log tree commit diff
path: root/third_party/lisp/cl-json.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/lisp/cl-json.nix')
-rw-r--r--third_party/lisp/cl-json.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/third_party/lisp/cl-json.nix b/third_party/lisp/cl-json.nix
index 0c77718ef0..b0362ff313 100644
--- a/third_party/lisp/cl-json.nix
+++ b/third_party/lisp/cl-json.nix
@@ -1,15 +1,16 @@
 # JSON encoder & decoder
 { pkgs, ... }:
 
+with pkgs.nix;
 let src = pkgs.third_party.fetchFromGitHub {
   owner = "hankhero";
   repo = "cl-json";
   rev = "6dfebb9540bfc3cc33582d0c03c9ec27cb913e79";
   sha256 = "0fx3m3x3s5ji950yzpazz4s0img3l6b3d6l3jrfjv0lr702496lh";
 };
-in pkgs.nix.buildLisp.library {
+in buildLisp.library {
   name = "cl-json";
-  deps = [ pkgs.third_party.lisp.asdf ];
+  deps = [ (buildLisp.bundled "asdf") ];
 
   srcs = [ "${src}/cl-json.asd" ] ++
   (map (f: src + ("/src/" + f)) [