about summary refs log tree commit diff
path: root/third_party/lisp/cl-json.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2020-01-26T23·59+0000
committerVincent Ambo <tazjin@google.com>2020-01-26T23·59+0000
commita41b8c70a68b3b6d848d708cd8058866b23847e6 (patch)
tree18cf49e0e1adce9c780e45909c7e14de4063b27a /third_party/lisp/cl-json.nix
parentca60eafa808e2423fd64996b4f678b08ed3277a5 (diff)
refactor(third_party/lisp): Use buildLisp.bundled for built-in libs r/462
Deprecates derivations for:

* sb-bsd-sockets
* sb-posix
* sb-rotate-byte
* uiop
Diffstat (limited to 'third_party/lisp/cl-json.nix')
-rw-r--r--third_party/lisp/cl-json.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/third_party/lisp/cl-json.nix b/third_party/lisp/cl-json.nix
index 0c77718ef0..b0362ff313 100644
--- a/third_party/lisp/cl-json.nix
+++ b/third_party/lisp/cl-json.nix
@@ -1,15 +1,16 @@
 # JSON encoder & decoder
 { pkgs, ... }:
 
+with pkgs.nix;
 let src = pkgs.third_party.fetchFromGitHub {
   owner = "hankhero";
   repo = "cl-json";
   rev = "6dfebb9540bfc3cc33582d0c03c9ec27cb913e79";
   sha256 = "0fx3m3x3s5ji950yzpazz4s0img3l6b3d6l3jrfjv0lr702496lh";
 };
-in pkgs.nix.buildLisp.library {
+in buildLisp.library {
   name = "cl-json";
-  deps = [ pkgs.third_party.lisp.asdf ];
+  deps = [ (buildLisp.bundled "asdf") ];
 
   srcs = [ "${src}/cl-json.asd" ] ++
   (map (f: src + ("/src/" + f)) [