about summary refs log tree commit diff
path: root/ops/nixos.nix
diff options
context:
space:
mode:
Diffstat (limited to 'ops/nixos.nix')
-rw-r--r--ops/nixos.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/ops/nixos.nix b/ops/nixos.nix
index 6a583c53db..37b2417f07 100644
--- a/ops/nixos.nix
+++ b/ops/nixos.nix
@@ -8,6 +8,13 @@ in rec {
     _module.args = {
       inherit (args) depot;
     };
+
+    # Ensure that pkgs == third_party.nix
+    nixpkgs.pkgs = depot.third_party.nixpkgs;
+    nix.nixPath = [
+      "nixos=${pkgs.path}"
+      "nixpath=${pkgs.path}"
+    ];
   };
 
   nixosFor = configuration: (depot.third_party.nixos {