about summary refs log tree commit diff
path: root/ops/nixos.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2021-04-19T21·58+0200
committertazjin <mail@tazj.in>2021-04-20T10·43+0000
commit5f19e8e6a73f7d76fa4bb62036891e824b64b515 (patch)
treed108bb45411c1757bc2dc22f5b7522edacab00f6 /ops/nixos.nix
parentd485ebf01a7e554bd8d43fb17e4a19d6145a6a6b (diff)
refactor(ops/nixos): Ensure that pkgs == depot.third_party.nixpkgs r/2527
This is currently done ad-hoc in a bunch of our systems, but we should
just do it centrally.

The commit message is a bit of a lie, as this doesn't yet update
grfn's systems.

Change-Id: Ic771c1a1da78ec5de9cffbf94c296dce5e11fd84
Reviewed-on: https://cl.tvl.fyi/c/depot/+/3047
Tested-by: BuildkiteCI
Reviewed-by: sterni <sternenseemann@systemli.org>
Diffstat (limited to 'ops/nixos.nix')
-rw-r--r--ops/nixos.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/ops/nixos.nix b/ops/nixos.nix
index 6a583c53db..37b2417f07 100644
--- a/ops/nixos.nix
+++ b/ops/nixos.nix
@@ -8,6 +8,13 @@ in rec {
     _module.args = {
       inherit (args) depot;
     };
+
+    # Ensure that pkgs == third_party.nix
+    nixpkgs.pkgs = depot.third_party.nixpkgs;
+    nix.nixPath = [
+      "nixos=${pkgs.path}"
+      "nixpath=${pkgs.path}"
+    ];
   };
 
   nixosFor = configuration: (depot.third_party.nixos {