about summary refs log tree commit diff
path: root/ops/nixos.nix
diff options
context:
space:
mode:
Diffstat (limited to 'ops/nixos.nix')
-rw-r--r--ops/nixos.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/ops/nixos.nix b/ops/nixos.nix
index 0fdb50a99b..19ba0168c0 100644
--- a/ops/nixos.nix
+++ b/ops/nixos.nix
@@ -5,10 +5,6 @@ let inherit (lib) findFirst isAttrs;
 in rec {
   # This provides our standard set of arguments to all NixOS modules.
   baseModule = { ... }: {
-    _module.args = {
-      inherit (args) depot;
-    };
-
     # Ensure that pkgs == third_party.nix
     nixpkgs.pkgs = depot.third_party.nixpkgs;
     nix.nixPath = [
@@ -24,6 +20,10 @@ in rec {
         configuration
       ];
     };
+
+    specialArgs = {
+      inherit (args) depot;
+    };
   });
 
   findSystem = hostname: