about summary refs log tree commit diff
path: root/ops/nixos.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2021-05-24T21·29+0200
committertazjin <mail@tazj.in>2021-05-24T21·48+0000
commit4a89bcd6a5cd409731d7d80fe3dbe364ba00c187 (patch)
treedb714c2e4332b31e48c8981a8e2f70e5073eed52 /ops/nixos.nix
parent0491fb24bf0493083e3084352987dd39fefad568 (diff)
refactor(ops/nixos): Pass `depot` as a special argument r/2626
This changes the evaluation order for the `depot` argument and ensures
it is partially evaluated before the module system starts resolving
imports.

This way we can import modules from `depot.path` without `depot`
having to come from readTree.

Fixes b/129.

Change-Id: Icf4dd2be15011055dac8b27e991a4ff6a12bf827
Reviewed-on: https://cl.tvl.fyi/c/depot/+/3156
Tested-by: BuildkiteCI
Reviewed-by: grfn <grfn@gws.fyi>
Diffstat (limited to 'ops/nixos.nix')
-rw-r--r--ops/nixos.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/ops/nixos.nix b/ops/nixos.nix
index 0fdb50a99b..19ba0168c0 100644
--- a/ops/nixos.nix
+++ b/ops/nixos.nix
@@ -5,10 +5,6 @@ let inherit (lib) findFirst isAttrs;
 in rec {
   # This provides our standard set of arguments to all NixOS modules.
   baseModule = { ... }: {
-    _module.args = {
-      inherit (args) depot;
-    };
-
     # Ensure that pkgs == third_party.nix
     nixpkgs.pkgs = depot.third_party.nixpkgs;
     nix.nixPath = [
@@ -24,6 +20,10 @@ in rec {
         configuration
       ];
     };
+
+    specialArgs = {
+      inherit (args) depot;
+    };
   });
 
   findSystem = hostname: