about summary refs log tree commit diff
path: root/nix/utils/tests/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/utils/tests/default.nix')
-rw-r--r--nix/utils/tests/default.nix11
1 files changed, 0 insertions, 11 deletions
diff --git a/nix/utils/tests/default.nix b/nix/utils/tests/default.nix
index d5159a8433..344a1771d7 100644
--- a/nix/utils/tests/default.nix
+++ b/nix/utils/tests/default.nix
@@ -15,7 +15,6 @@ let
     isSymlink
     pathType
     storePathName
-    onlyDrvPath
     ;
 
   assertUtilsPred = msg: act: exp: [
@@ -92,19 +91,9 @@ let
       (storePathName cleanedSource)
       cleanedSource.name)
   ];
-
-  onlyDrvPathTests = it "correctly updates the string context of drvPath" [
-    (assertEq "onlyDrvPath only produces path dependencies"
-      (builtins.all
-        (dep: dep.path or false)
-        (builtins.attrValues
-          (builtins.getContext (onlyDrvPath depot.tools.cheddar))))
-      true)
-  ];
 in
 
 runTestsuite "nix.utils" [
   pathPredicates
   storePathNameTests
-  onlyDrvPathTests
 ]