about summary refs log tree commit diff
path: root/nix/tag/tests.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/tag/tests.nix')
-rw-r--r--nix/tag/tests.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/nix/tag/tests.nix b/nix/tag/tests.nix
index bcc42c758a..e0085b4837 100644
--- a/nix/tag/tests.nix
+++ b/nix/tag/tests.nix
@@ -4,6 +4,7 @@ let
   inherit (depot.nix.runTestsuite)
     runTestsuite
     assertEq
+    assertThrows
     it
     ;
 
@@ -50,6 +51,10 @@ let
         { int = lib.isInt; }
       ] "foo")
       { def = "foo"; })
+    (assertThrows "throws failing to match"
+      (discr [
+        { fish = x: x == 42; }
+      ] 21))
   ];
 
   match-test = it "can match things" [