about summary refs log tree commit diff
path: root/nix/tag/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/tag/default.nix')
-rw-r--r--nix/tag/default.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nix/tag/default.nix b/nix/tag/default.nix
index 0038404460..2955656323 100644
--- a/nix/tag/default.nix
+++ b/nix/tag/default.nix
@@ -78,7 +78,7 @@ let
   # Like `discrDef`, but fail if there is no match.
   discr = fs: v:
     let res = discrDef null fs v; in
-    assert lib.assertMsg (res != null)
+    assert lib.assertMsg (res != { })
       "tag.discr: No predicate found that matches ${lib.generators.toPretty {} v}";
     res;