about summary refs log tree commit diff
path: root/nix/dependency-analyzer/examples/ci-targets.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/dependency-analyzer/examples/ci-targets.nix')
-rw-r--r--nix/dependency-analyzer/examples/ci-targets.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/nix/dependency-analyzer/examples/ci-targets.nix b/nix/dependency-analyzer/examples/ci-targets.nix
new file mode 100644
index 0000000000..597abd4109
--- /dev/null
+++ b/nix/dependency-analyzer/examples/ci-targets.nix
@@ -0,0 +1,12 @@
+{ depot, lib, ... }:
+
+(
+  depot.nix.dependency-analyzer.knownDependencyGraph
+    "depot"
+    depot.ci.targets
+).overrideAttrs (old: {
+  # Causes an infinite recursion via ci.targets otherwise
+  meta = lib.recursiveUpdate (old.meta or { }) {
+    ci.skip = true;
+  };
+})