about summary refs log tree commit diff
path: root/nix/buildLisp/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/buildLisp/default.nix')
-rw-r--r--nix/buildLisp/default.nix14
1 files changed, 6 insertions, 8 deletions
diff --git a/nix/buildLisp/default.nix b/nix/buildLisp/default.nix
index 9d6ce4edda..0d68a2818b 100644
--- a/nix/buildLisp/default.nix
+++ b/nix/buildLisp/default.nix
@@ -8,7 +8,7 @@
 
 let
   inherit (builtins) map elemAt match filter;
-  inherit (pkgs) lib runCommandNoCC makeWrapper writeText writeShellScriptBin sbcl ecl-static ccl;
+  inherit (pkgs) lib runCommand makeWrapper writeText writeShellScriptBin sbcl ecl-static ccl;
   inherit (pkgs.stdenv) targetPlatform;
 
   #
@@ -154,8 +154,7 @@ let
           let
             implementation = old.implementation or defaultImplementation;
             brokenOn = old.brokenOn or [ ];
-            # TODO(sterni): https://github.com/Clozure/ccl/issues/405
-            targets = lib.subtractLists (brokenOn ++ [ "ccl" implementation.name ])
+            targets = lib.subtractLists (brokenOn ++ [ implementation.name ])
               (builtins.attrNames impls);
           in
           {
@@ -188,7 +187,7 @@ let
       lispNativeDeps = allNative native lispDeps;
       filteredSrcs = implFilter implementation srcs;
     in
-    runCommandNoCC name
+    runCommand name
       {
         LD_LIBRARY_PATH = lib.makeLibraryPath lispNativeDeps;
         LANG = "C.UTF-8";
@@ -476,7 +475,7 @@ let
           } $@
         '';
 
-      bundled = name: runCommandNoCC "${name}-cllib"
+      bundled = name: runCommand "${name}-cllib"
         {
           passthru = {
             lispName = name;
@@ -514,7 +513,6 @@ let
 
       # See https://ccl.clozure.com/docs/ccl.html#building-definitions
       faslExt =
-        /**/
         if targetPlatform.isPower && targetPlatform.is32bit then "pfsl"
         else if targetPlatform.isPower && targetPlatform.is64bit then "p64fsl"
         else if targetPlatform.isx86_64 && targetPlatform.isLinux then "lx64fsl"
@@ -641,7 +639,7 @@ let
             }
         else null;
     in
-    lib.fix (self: runCommandNoCC "${name}-cllib"
+    lib.fix (self: runCommand "${name}-cllib"
       {
         LD_LIBRARY_PATH = lib.makeLibraryPath lispNativeDeps;
         LANG = "C.UTF-8";
@@ -708,7 +706,7 @@ let
             }
         else null;
     in
-    lib.fix (self: runCommandNoCC "${name}"
+    lib.fix (self: runCommand "${name}"
       {
         nativeBuildInputs = [ makeWrapper ];
         LD_LIBRARY_PATH = libPath;