about summary refs log tree commit diff
path: root/fun/owothia/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'fun/owothia/shell.nix')
-rw-r--r--fun/owothia/shell.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/fun/owothia/shell.nix b/fun/owothia/shell.nix
new file mode 100644
index 0000000000..1ad70c907b
--- /dev/null
+++ b/fun/owothia/shell.nix
@@ -0,0 +1,22 @@
+{ pkgs ? (import ../../../. {}).third_party, ... }:
+
+let
+  inherit (pkgs)
+    haskellPackages
+    haskell
+    gitignoreSource
+    ;
+in
+
+(haskellPackages.extend (haskell.lib.packageSourceOverrides {
+  owothia = gitignoreSource ./.;
+})).shellFor {
+  packages = p: [ p.owothia ];
+  withHoogle = true;
+  doBenchmark = true;
+  buildInputs = with haskellPackages; [
+    cabal-install
+    hlint
+    haskell-language-server
+  ];
+}