about summary refs log tree commit diff
path: root/fun/owothia/shell.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2021-05-11T13·46+0200
committertazjin <mail@tazj.in>2021-05-11T21·34+0000
commit259cbfd0b271990639b0a02d83453acc0c18da1c (patch)
treeeaf07bc086f86c8da07f3e223dd8f230017f9cd8 /fun/owothia/shell.nix
parent13336c60570bef5e6a303a5c1fb76595dda07da8 (diff)
chore(owothia): move to //fun/owothia r/2577
Owothia graduates, or something.

Mostly I don't want infrastructure to depend on stuff in //users.

Does anyone know where owothia is running anyways?

Change-Id: I198c7ac935736c7aee3ba4fbda1453b82aa10283
Reviewed-on: https://cl.tvl.fyi/c/depot/+/3103
Tested-by: BuildkiteCI
Reviewed-by: grfn <grfn@gws.fyi>
Diffstat (limited to 'fun/owothia/shell.nix')
-rw-r--r--fun/owothia/shell.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/fun/owothia/shell.nix b/fun/owothia/shell.nix
new file mode 100644
index 0000000000..1ad70c907b
--- /dev/null
+++ b/fun/owothia/shell.nix
@@ -0,0 +1,22 @@
+{ pkgs ? (import ../../../. {}).third_party, ... }:
+
+let
+  inherit (pkgs)
+    haskellPackages
+    haskell
+    gitignoreSource
+    ;
+in
+
+(haskellPackages.extend (haskell.lib.packageSourceOverrides {
+  owothia = gitignoreSource ./.;
+})).shellFor {
+  packages = p: [ p.owothia ];
+  withHoogle = true;
+  doBenchmark = true;
+  buildInputs = with haskellPackages; [
+    cabal-install
+    hlint
+    haskell-language-server
+  ];
+}