about summary refs log tree commit diff
path: root/users/glittershark/owothia/packageSet.nix
diff options
context:
space:
mode:
authorGriffin Smith <grfn@gws.fyi>2020-07-12T01·32-0400
committerglittershark <grfn@gws.fyi>2020-07-13T17·31+0000
commit2eb90cbca1c5a45243008912684cd9ea71d304c6 (patch)
treec0426248df4b5e4c6741c65647d2acee68b479e7 /users/glittershark/owothia/packageSet.nix
parent7e0b2cd3f36fd1bd0ef8fc0191f5887792c6d3a6 (diff)
feat(owothia): Add owothia r/1270
Add owothia, an irc bot that picks a random verb out of a random subset
of messages and replies with a message of the form "<verb> me owo".

it's incredibly messy, full of warnings, includes a *number* of harcoded
things, but also is hilarious.

Change-Id: I73cacd533bbbff9e753d1e542308da25247a7034
Reviewed-on: https://cl.tvl.fyi/c/depot/+/1063
Tested-by: BuildkiteCI
Reviewed-by: lukegb <lukegb@tvl.fyi>
Diffstat (limited to 'users/glittershark/owothia/packageSet.nix')
-rw-r--r--users/glittershark/owothia/packageSet.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/users/glittershark/owothia/packageSet.nix b/users/glittershark/owothia/packageSet.nix
new file mode 100644
index 0000000000..93812a0830
--- /dev/null
+++ b/users/glittershark/owothia/packageSet.nix
@@ -0,0 +1,20 @@
+{ pkgs ? (import ../../../. {}).third_party, ... }:
+
+let
+
+  hlib = pkgs.haskell.lib;
+
+in
+
+pkgs.haskellPackages.extend (self: super: {
+  regex-tdfa-text = hlib.doJailbreak
+    (hlib.appendPatch
+      super.regex-tdfa-text
+      ./regex-tdfa-text.patch
+    );
+
+  fullstop = hlib.dontCheck super.fullstop;
+
+  chatter = hlib.doJailbreak
+    (hlib.dontCheck (hlib.appendPatch super.chatter ./chatter.patch));
+})