about summary refs log tree commit diff
path: root/users/glittershark/owothia/packageSet.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/glittershark/owothia/packageSet.nix')
-rw-r--r--users/glittershark/owothia/packageSet.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/users/glittershark/owothia/packageSet.nix b/users/glittershark/owothia/packageSet.nix
new file mode 100644
index 0000000000..93812a0830
--- /dev/null
+++ b/users/glittershark/owothia/packageSet.nix
@@ -0,0 +1,20 @@
+{ pkgs ? (import ../../../. {}).third_party, ... }:
+
+let
+
+  hlib = pkgs.haskell.lib;
+
+in
+
+pkgs.haskellPackages.extend (self: super: {
+  regex-tdfa-text = hlib.doJailbreak
+    (hlib.appendPatch
+      super.regex-tdfa-text
+      ./regex-tdfa-text.patch
+    );
+
+  fullstop = hlib.dontCheck super.fullstop;
+
+  chatter = hlib.doJailbreak
+    (hlib.dontCheck (hlib.appendPatch super.chatter ./chatter.patch));
+})