about summary refs log tree commit diff
path: root/tvix/eval/Cargo.toml
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2022-12-18T14·23+0300
committertazjin <tazjin@tvl.su>2022-12-21T13·23+0000
commit9d6ee5b6a69195bc1a3d5543f04998b631584076 (patch)
tree34794bf6cae65fecfd552a1b68cee84a1f4cf29d /tvix/eval/Cargo.toml
parent257c67f204c2a2d1ca8a1d0ac266312167a170eb (diff)
fix(tvix/eval): use test-generator fork that supports workspaces r/5442
This should make no difference in Nix builds, but allows running tests
locally again with `cargo test` for //tvix/eval.

Change-Id: I97d61840143d5c14db61d5862781bf635f9a28e7
Reviewed-on: https://cl.tvl.fyi/c/depot/+/7590
Reviewed-by: grfn <grfn@gws.fyi>
Tested-by: BuildkiteCI
Reviewed-by: flokli <flokli@flokli.de>
Diffstat (limited to 'tvix/eval/Cargo.toml')
-rw-r--r--tvix/eval/Cargo.toml7
1 files changed, 6 insertions, 1 deletions
diff --git a/tvix/eval/Cargo.toml b/tvix/eval/Cargo.toml
index b08dc139a9..93d45c2166 100644
--- a/tvix/eval/Cargo.toml
+++ b/tvix/eval/Cargo.toml
@@ -27,11 +27,16 @@ rnix = "0.11.0"
 
 [dev-dependencies]
 criterion = "0.4"
-test-generator = "0.3.0"
 pretty_assertions = "1.2.1"
 itertools = "0.10.3"
 tempdir = "0.3.7"
 
+[dev-dependencies.test-generator]
+# This fork of test-generator adds support for cargo workspaces, see
+# also https://github.com/frehberg/test-generator/pull/14
+git = "https://github.com/JamesGuthrie/test-generator.git"
+rev = "82e799979980962aec1aa324ec6e0e4cad781f41"
+
 [features]
 default = [ "impure", "arbitrary", "nix_tests", "backtrace_overflow" ]