about summary refs log tree commit diff
path: root/tvix/eval/Cargo.toml
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2022-12-16T11·54+0300
committertazjin <tazjin@tvl.su>2022-12-21T13·23+0000
commit257c67f204c2a2d1ca8a1d0ac266312167a170eb (patch)
tree2cd7f15cb4f47a0083c273ab1b0b7ff8f9a5f688 /tvix/eval/Cargo.toml
parentd9e2bec953880ecb5953b61b36a5beaec0565e22 (diff)
chore(tvix): upgrade to clap 4.0 r/5441
In //tvix/eval:

* criterion bumped to 4.0, which at least depends on clap 3.x instead
  of 2.x, which is less incompatible

In //tvix/cli:

* no changes required

In //tvix/nix_cli:

* some minor changes for compatibility with clap 4.0, no functionality
  changes

Change-Id: If793f64b59fcaa2402d3d483ddbab4092f32df03
Reviewed-on: https://cl.tvl.fyi/c/depot/+/7588
Reviewed-by: grfn <grfn@gws.fyi>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/eval/Cargo.toml')
-rw-r--r--tvix/eval/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/tvix/eval/Cargo.toml b/tvix/eval/Cargo.toml
index e4282507d7..b08dc139a9 100644
--- a/tvix/eval/Cargo.toml
+++ b/tvix/eval/Cargo.toml
@@ -26,7 +26,7 @@ backtrace-on-stack-overflow = { version = "0.2.0", optional = true }
 rnix = "0.11.0"
 
 [dev-dependencies]
-criterion = "0.3.6"
+criterion = "0.4"
 test-generator = "0.3.0"
 pretty_assertions = "1.2.1"
 itertools = "0.10.3"