about summary refs log tree commit diff
path: root/tools/nixery/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2019-08-13T22·03+0100
committerVincent Ambo <github@tazj.in>2019-08-13T23·02+0100
commitd9168e3e4d8ee0be01cbe994d171d933af215f2c (patch)
tree9d21cc8f338b74bce486212d526dfb5080753e63 /tools/nixery/default.nix
parent3939722063f3d08a547fa98e17aac609f7f765ac (diff)
refactor(build-image): Extract package set loading into helper
Some upcoming changes might require the Nix build to be split into
multiple separate nix-build invocations of different expressions, thus
splitting this out is useful.

It also fixes an issue where `build-image/default.nix` might be called
in an environment where no Nix channels are configured.
Diffstat (limited to 'tools/nixery/default.nix')
-rw-r--r--tools/nixery/default.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/tools/nixery/default.nix b/tools/nixery/default.nix
index 686c230553..734a72d57e 100644
--- a/tools/nixery/default.nix
+++ b/tools/nixery/default.nix
@@ -25,7 +25,9 @@ rec {
   nixery-server = callPackage ./server { };
 
   # Implementation of the image building & layering logic
-  nixery-build-image = (import ./build-image { inherit pkgs; }).wrapper;
+  nixery-build-image = (import ./build-image {
+    pkgSource = "path!${<nixpkgs>}";
+  }).wrapper;
 
   # Use mdBook to build a static asset page which Nixery can then
   # serve. This is primarily used for the public instance at