about summary refs log tree commit diff
path: root/tools/nixery/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2019-08-12T23·35+0100
committerVincent Ambo <github@tazj.in>2019-08-13T23·02+0100
commit3939722063f3d08a547fa98e17aac609f7f765ac (patch)
treeb8bc2fb7d7bdc8e78a92a79ff58d336deca10de8 /tools/nixery/default.nix
parent6285cd8dbfb77c287fc5b30263bbfd5770b47413 (diff)
style: Apply nixfmt to trivial Nix files
ALl the ones except for build-image.nix are considered trivial. On the
latter, nixfmt makes some useful changes but by-and-large it is not
ready for that code yet.
Diffstat (limited to 'tools/nixery/default.nix')
-rw-r--r--tools/nixery/default.nix9
1 files changed, 4 insertions, 5 deletions
diff --git a/tools/nixery/default.nix b/tools/nixery/default.nix
index 926ab0d19f..686c230553 100644
--- a/tools/nixery/default.nix
+++ b/tools/nixery/default.nix
@@ -11,8 +11,7 @@
 # WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
 # See the License for the specific language governing permissions and
 # limitations under the License.
-{ pkgs ? import <nixpkgs> {}
-, preLaunch ? "" }:
+{ pkgs ? import <nixpkgs> { }, preLaunch ? "" }:
 
 with pkgs;
 
@@ -23,7 +22,7 @@ rec {
   # Users will usually not want to use this directly, instead see the
   # 'nixery' derivation below, which automatically includes runtime
   # data dependencies.
-  nixery-server = callPackage ./server {};
+  nixery-server = callPackage ./server { };
 
   # Implementation of the image building & layering logic
   nixery-build-image = (import ./build-image { inherit pkgs; }).wrapper;
@@ -31,7 +30,7 @@ rec {
   # Use mdBook to build a static asset page which Nixery can then
   # serve. This is primarily used for the public instance at
   # nixery.dev.
-  nixery-book = callPackage ./docs {};
+  nixery-book = callPackage ./docs { };
 
   # Wrapper script running the Nixery server with the above two data
   # dependencies configured.
@@ -76,7 +75,7 @@ rec {
     '';
   in dockerTools.buildLayeredImage {
     name = "nixery";
-    config.Cmd = ["${nixery-launch-script}/bin/nixery"];
+    config.Cmd = [ "${nixery-launch-script}/bin/nixery" ];
     maxLayers = 96;
     contents = [
       cacert