about summary refs log tree commit diff
path: root/third_party/loxy/default.nix
diff options
context:
space:
mode:
authoredef <edef@edef.eu>2020-08-03T10·23+0000
committeredef <edef@edef.eu>2020-08-03T10·32+0000
commitc17be2364eda44a6ccbcb77fc86978fd7fffe6b2 (patch)
treebf6a3ba09cef92d61e471dc9c8e17db7ac86a8fa /third_party/loxy/default.nix
parent8d6fcbe1a5e4791d81d2a83b89407f8d2d4d8362 (diff)
chore(3p/loxy): Move //users/edef/loxy to //third_party r/1560
Change-Id: Ia451d190d4e415ef875c51ebeca12c7c5dc72342
Reviewed-on: https://cl.tvl.fyi/c/depot/+/1590
Tested-by: BuildkiteCI
Reviewed-by: lukegb <lukegb@tvl.fyi>
Reviewed-by: tazjin <mail@tazj.in>
Diffstat (limited to 'third_party/loxy/default.nix')
-rw-r--r--third_party/loxy/default.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/third_party/loxy/default.nix b/third_party/loxy/default.nix
new file mode 100644
index 0000000000..d1399f3ea9
--- /dev/null
+++ b/third_party/loxy/default.nix
@@ -0,0 +1,31 @@
+{ lib, pkgs, depot, ... }:
+
+let
+
+  inherit (depot.nix) fetchGoModule;
+
+in
+
+pkgs.buildGoModule rec {
+  pname = "loxy";
+  version = "0.1.1";
+
+  src = fetchGoModule {
+    path = "go.anomalous.eu/loxy";
+    inherit version;
+    sha256 = "0k1i7wa0v9h7r4kb7pjd3pzvcjrnsp58cfh51z73s74il7462sr5";
+  };
+
+  vendorSha256 = "0243wq6crzy86vc5cm1nijddsrcllr3c66xkd6q8x16jrvnv09jx";
+
+  postInstall = ''
+    install -D -m 0644 -t $out/share/man/man8 loxy.8
+  '';
+
+  meta = with lib; {
+    description = "a logging IRC proxy";
+    homepage = "https://anomalous.eu/projects/loxy";
+    license = licenses.gpl3Plus;
+    maintainers = with maintainers; [ V edef ];
+  };
+}