about summary refs log tree commit diff
path: root/third_party/loxy/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/loxy/default.nix')
-rw-r--r--third_party/loxy/default.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/third_party/loxy/default.nix b/third_party/loxy/default.nix
new file mode 100644
index 0000000000..d1399f3ea9
--- /dev/null
+++ b/third_party/loxy/default.nix
@@ -0,0 +1,31 @@
+{ lib, pkgs, depot, ... }:
+
+let
+
+  inherit (depot.nix) fetchGoModule;
+
+in
+
+pkgs.buildGoModule rec {
+  pname = "loxy";
+  version = "0.1.1";
+
+  src = fetchGoModule {
+    path = "go.anomalous.eu/loxy";
+    inherit version;
+    sha256 = "0k1i7wa0v9h7r4kb7pjd3pzvcjrnsp58cfh51z73s74il7462sr5";
+  };
+
+  vendorSha256 = "0243wq6crzy86vc5cm1nijddsrcllr3c66xkd6q8x16jrvnv09jx";
+
+  postInstall = ''
+    install -D -m 0644 -t $out/share/man/man8 loxy.8
+  '';
+
+  meta = with lib; {
+    description = "a logging IRC proxy";
+    homepage = "https://anomalous.eu/projects/loxy";
+    license = licenses.gpl3Plus;
+    maintainers = with maintainers; [ V edef ];
+  };
+}