about summary refs log tree commit diff
path: root/fun/paroxysm/default.nix
diff options
context:
space:
mode:
authoreta <eta@theta.eu.org>2020-08-28T23·18+0100
committereta <eta@theta.eu.org>2020-08-28T23·57+0000
commit9e118c6d69cfe69f1d133bd6de76c949fda23c1a (patch)
treec1d7d54de9b2e7a4d5f711e9bb7a867841faab01 /fun/paroxysm/default.nix
parent13088392e2fbb358b00fb5f6a3b9c16928d70a97 (diff)
feat(paroxysm): upload queries for all quotes to eta's pastebin r/1733
- Currently, asking for all your quotes either stalls the bot, or
  doesn't result in you getting all your quotes, or both. This aims
  to resolve this oversight by shoving them all in a pastebin.
- This uses the lovely `crimp` library by tazjin, which is really
  good at just doing HTTP stuff with minimal fuss. Amazing!
  (although we should probably actually use the depot version)
- Everything is hard coded for now, but we probably don't care.
- Stuff expires after 24 hours, for privacy reasons?
- We also had to add a function to format entries without colours,
  and took the opportunity to clean up the format!() a bit.

Change-Id: I6e75968c7da48a51fff327355b8fa2c025d0db75
Reviewed-on: https://cl.tvl.fyi/c/depot/+/1872
Tested-by: BuildkiteCI
Reviewed-by: glittershark <grfn@gws.fyi>
Reviewed-by: lukegb <lukegb@tvl.fyi>
Diffstat (limited to 'fun/paroxysm/default.nix')
-rw-r--r--fun/paroxysm/default.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/fun/paroxysm/default.nix b/fun/paroxysm/default.nix
index b6eefc7a2e..dafd3cbb61 100644
--- a/fun/paroxysm/default.nix
+++ b/fun/paroxysm/default.nix
@@ -5,12 +5,13 @@ let
 in
 pkgs.naersk.buildPackage {
   name = "paroxysm";
-  version = "0.0.1";
+  version = "0.0.2";
   src = ./.;
 
   buildInputs = with pkgs; [
     openssl
     pkgconfig
     postgresql.lib
+    curl
   ];
 }