about summary refs log tree commit diff
path: root/fun/paroxysm/Cargo.toml
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2020-08-01T23·40+0100
committertazjin <mail@tazj.in>2020-08-02T02·16+0000
commite663ca4128ee04bb6b4e9f2b62120a55a8c3ccea (patch)
treeb8cd03558564215cd004972454ecbc82d8e20670 /fun/paroxysm/Cargo.toml
parent194c498d53ed68a9c70d548008e60eb7bdcbd59a (diff)
refactor(paroxysm): Use derive macros from serde crate r/1543
serde_derive is deprecated, the macros have moved behind a
feature-gate in serde itself.

Change-Id: Ib42e7463a81006e23a4fe8a0e48f494610dc8e4c
Reviewed-on: https://cl.tvl.fyi/c/depot/+/1550
Tested-by: BuildkiteCI
Reviewed-by: kanepyork <rikingcoding@gmail.com>
Diffstat (limited to 'fun/paroxysm/Cargo.toml')
-rw-r--r--fun/paroxysm/Cargo.toml3
1 files changed, 1 insertions, 2 deletions
diff --git a/fun/paroxysm/Cargo.toml b/fun/paroxysm/Cargo.toml
index 91a68d4f06..a60883533a 100644
--- a/fun/paroxysm/Cargo.toml
+++ b/fun/paroxysm/Cargo.toml
@@ -14,8 +14,7 @@ lazy_static = "1.2.0"
 log = "0.4.6"
 rand = "0.7.3"
 regex = "1.1.0"
-serde = "1.0.81"
-serde_derive = "1.0.81"
+serde = { version = "1.0", features = [ "derive" ] }
 
 [dependencies.diesel]
 features = ["postgres", "chrono", "r2d2"]