about summary refs log tree commit diff
path: root/fun/owothia/pkg.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2021-05-11T13·46+0200
committertazjin <mail@tazj.in>2021-05-11T21·34+0000
commit259cbfd0b271990639b0a02d83453acc0c18da1c (patch)
treeeaf07bc086f86c8da07f3e223dd8f230017f9cd8 /fun/owothia/pkg.nix
parent13336c60570bef5e6a303a5c1fb76595dda07da8 (diff)
chore(owothia): move to //fun/owothia r/2577
Owothia graduates, or something.

Mostly I don't want infrastructure to depend on stuff in //users.

Does anyone know where owothia is running anyways?

Change-Id: I198c7ac935736c7aee3ba4fbda1453b82aa10283
Reviewed-on: https://cl.tvl.fyi/c/depot/+/3103
Tested-by: BuildkiteCI
Reviewed-by: grfn <grfn@gws.fyi>
Diffstat (limited to 'fun/owothia/pkg.nix')
-rw-r--r--fun/owothia/pkg.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/fun/owothia/pkg.nix b/fun/owothia/pkg.nix
new file mode 100644
index 0000000000..d0941a8489
--- /dev/null
+++ b/fun/owothia/pkg.nix
@@ -0,0 +1,16 @@
+{ mkDerivation, base, bytestring, chatter, containers, envy
+, irc-client, lens, lib, random, relude, text
+}:
+mkDerivation {
+  pname = "owothia";
+  version = "0.0.1.0";
+  src = ./.;
+  isLibrary = false;
+  isExecutable = true;
+  executableHaskellDepends = [
+    base bytestring chatter containers envy irc-client lens random
+    relude text
+  ];
+  license = "unknown";
+  hydraPlatforms = lib.platforms.none;
+}