about summary refs log tree commit diff
path: root/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2019-09-02T00·24+0100
committerVincent Ambo <tazjin@google.com>2019-09-02T00·24+0100
commitb43e5529f770818710fffd2458e320f49272d26f (patch)
tree6db312785f934137d3245b2f6261986a576b263b /default.nix
parenta635beabfa965436e411d76473714f8b53d29549 (diff)
feat(third_party): Add missing Quicklisp packages for Gemma r/69
Gemma depends on cl-prevalence, which isn't in the nixpkgs Quicklisp
snapshot.

This adds the package and its dependencies to the overlay.
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/default.nix b/default.nix
index e5a384ca12..71ac4c3c6e 100644
--- a/default.nix
+++ b/default.nix
@@ -50,6 +50,13 @@ let
       rev = "14f9ee66e63077539252f8b4550049381a082518";
       sha256 = "1wn7nmb1cqfk2j91l3rwc6yhimfkzxprb8wknw5wi57yhq9m6lv1";
     }) {}).elmPackages;
+
+    # One of Gemma's dependencies is missing in nixpkgs' Quicklisp
+    # package set, it is overlaid locally here.
+    lispPackages = import ./third_party/common_lisp/quicklisp.nix {
+      inherit (self) lib;
+      inherit (super) lispPackages;
+    };
   };
 
 in { ... } @ args: import stableSrc (args // {