about summary refs log tree commit diff
path: root/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2019-09-02T00·24+0100
committerVincent Ambo <tazjin@google.com>2019-09-02T00·24+0100
commita635beabfa965436e411d76473714f8b53d29549 (patch)
tree9f0edd719b9b57b120d8287d5da5be35e5270959 /default.nix
parenta58af3e371591ed7a7015350512ca46accbf37d6 (diff)
fix: Correct naming of variables in overlay function r/68
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix18
1 files changed, 9 insertions, 9 deletions
diff --git a/default.nix b/default.nix
index caad071c30..e5a384ca12 100644
--- a/default.nix
+++ b/default.nix
@@ -22,29 +22,29 @@ let
   };
   unstable = import unstableSrc {};
 
-  localPkgs = super: pkgs: {
+  localPkgs = self: super: {
     # Local projects should be added here:
     tazjin = {
-      blog = import ./services/tazblog { inherit pkgs; };
-      blog_cli = pkgs.callPackage ./tools/blog_cli {};
-      gemma = pkgs.callPackage ./services/gemma {};
+      blog = import ./services/tazblog { pkgs = self; };
+      blog_cli = self.callPackage ./tools/blog_cli {};
+      gemma = self.callPackage ./services/gemma {};
     };
 
     # Third-party projects (either vendored or modified from nixpkgs) go here:
-    gitAppraise = pkgs.callPackage ./third_party/go/git-appraise/git-appraise {};
+    gitAppraise = self.callPackage ./third_party/go/git-appraise/git-appraise {};
 
-    nixery = import ./third_party/nixery.nix { pkgs = super; };
+    nixery = import ./third_party/nixery.nix { pkgs = self; };
     terraform-gcp = unstable.terraform_0_12.withPlugins(p: [ p.google p.google-beta ]);
-    ormolu = import (super.fetchFromGitHub {
+    ormolu = import (self.fetchFromGitHub {
       owner = "tweag";
       repo = "ormolu";
       rev = "a7076c0f83e5c06ea9067b71171859fa2ba8afd9";
       sha256 = "1p4n2ja4ciw3qfskn65ggpy37mvgf2sslxqmqn8s8jjarnqcyfny";
-    }) { pkgs = super; };
+    }) { pkgs = self; };
 
     # Gemma needs an older version of Elm to be built. Updating it to
     # the newer version is a lot of effort.
-    elmPackages = (import (super.fetchFromGitHub {
+    elmPackages = (import (self.fetchFromGitHub {
       owner = "NixOS";
       repo = "nixpkgs";
       rev = "14f9ee66e63077539252f8b4550049381a082518";