about summary refs log tree commit diff
path: root/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2023-08-21T21·45+0300
committertazjin <tazjin@tvl.su>2023-09-06T13·38+0000
commit110328232ddee8aec755142e3098ba07914b8322 (patch)
tree5e865d27ab4fe44b27ac9e7e352778cf16fc14d4 /default.nix
parent1aa8b62ae31055beb435a310a22a9ca3c9c8e63c (diff)
chore(3p/sources): bump channels & overlays (2023-08-21) r/6560
Included changes:

* tvix/eval: enable some lang tests on nix_latest

  Nix 2.16 contains some breaking language changes which Tvix does
  not yet implement, but the existing tests for them are now passed by
  Nix 2.16 (but not yet by Tvix).

* tvix/eval: disable a lang test on nix_latest

  In Nix 2.17, the identifier formatting test fails because some
  behaviour changed. We have not investigated further yet.

* 3p/overlays: use version of ihp-hsx that works with GHC 9.4

  Originally from the separate cl/9185.

* top-level: introduce a mechanism to exclude build targets from CI in
  the top level. This fixes b/296.

* users/grfn: disable builds of xanthous (and dependents) until the
  CLs fixing its build are submitted

* 3p/overlays: build nixos-option against Nix 2.15, the only version
  with which it builds

* 3p/overlays: bump tdlib to 1.8.16

Change-Id: Ia377f39dbdb08ac45ff830a615e64babc091e5ee
Reviewed-on: https://cl.tvl.fyi/c/depot/+/9125
Reviewed-by: flokli <flokli@flokli.de>
Tested-by: BuildkiteCI
Autosubmit: tazjin <tazjin@tvl.su>
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix26
1 files changed, 18 insertions, 8 deletions
diff --git a/default.nix b/default.nix
index 2969da9b9b..0cb74ee731 100644
--- a/default.nix
+++ b/default.nix
@@ -71,8 +71,8 @@ let
   # To determine build targets, we walk through the depot tree and
   # fetch attributes that were imported by readTree and are buildable.
   #
-  # Any build target that contains `meta.ci.skip = true` will be skipped.
-
+  # Any build target that contains `meta.ci.skip = true` or is marked
+  # broken will be skipped.
   # Is this tree node eligible for build inclusion?
   eligible = node: (node ? outPath) && !(node.meta.ci.skip or (node.meta.broken or false));
 
@@ -103,16 +103,26 @@ readTree.fix (self: (readDepot {
     filter = self.third_party.nixpkgs.lib.cleanSourceFilter;
   };
 
+  # Additionally targets can be excluded from CI by adding them to the
+  # list below.
+  ci.excluded = [
+    # xanthous and related targets are disabled until cl/9186 is submitted
+    self.users.grfn.xanthous
+    self.users.grfn.system.system.mugwumpSystem
+  ];
+
   # List of all buildable targets, for CI purposes.
   #
   # Note: To prevent infinite recursion, this *must* be a nested
   # attribute set (which does not have a __readTree attribute).
-  ci.targets = readTree.gather eligible (self // {
-    # remove the pipelines themselves from the set over which to
-    # generate pipelines because that also leads to infinite
-    # recursion.
-    ops = self.ops // { pipelines = null; };
-  });
+  ci.targets = readTree.gather
+    (t: (eligible t) && (!builtins.elem t self.ci.excluded))
+    (self // {
+      # remove the pipelines themselves from the set over which to
+      # generate pipelines because that also leads to infinite
+      # recursion.
+      ops = self.ops // { pipelines = null; };
+    });
 
   # Derivation that gcroots all depot targets.
   ci.gcroot = with self.third_party.nixpkgs; writeText "depot-gcroot"