about summary refs log tree commit diff
path: root/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2023-09-05T22·50+0300
committertazjin <tazjin@tvl.su>2023-09-06T08·40+0000
commit1aa8b62ae31055beb435a310a22a9ca3c9c8e63c (patch)
tree166b98ab3102a3cad2c99832cb2bc011f3e72005 /default.nix
parent7923cc19f698bdd128f93087d203cd6182b21ef2 (diff)
chore(depot): skip builds for broken packages r/6559
Considers `note.meta.broken` in addition to `node.meta.ci.skip`,
because people might be inheriting this from something, or using an
extremely complicated package mechanism in which setting their own
meta attributes is ugly/non-trivial.

Change-Id: Ia93cfbba6af545e370a7c7dbd51f24e1df68bbf7
Reviewed-on: https://cl.tvl.fyi/c/depot/+/9270
Tested-by: BuildkiteCI
Autosubmit: tazjin <tazjin@tvl.su>
Reviewed-by: flokli <flokli@flokli.de>
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/default.nix b/default.nix
index 832cc24481..2969da9b9b 100644
--- a/default.nix
+++ b/default.nix
@@ -74,7 +74,7 @@ let
   # Any build target that contains `meta.ci.skip = true` will be skipped.
 
   # Is this tree node eligible for build inclusion?
-  eligible = node: (node ? outPath) && !(node.meta.ci.skip or false);
+  eligible = node: (node ? outPath) && !(node.meta.ci.skip or (node.meta.broken or false));
 
 in
 readTree.fix (self: (readDepot {