about summary refs log tree commit diff
path: root/web/tvl/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'web/tvl/default.nix')
-rw-r--r--web/tvl/default.nix32
1 files changed, 21 insertions, 11 deletions
diff --git a/web/tvl/default.nix b/web/tvl/default.nix
index 262be54c0e..8bbc7d566a 100644
--- a/web/tvl/default.nix
+++ b/web/tvl/default.nix
@@ -4,7 +4,7 @@ with depot.nix.yants;
 
 let
   inherit (builtins) filter;
-  inherit (pkgs) graphviz runCommandNoCC writeText;
+  inherit (pkgs) graphviz runCommand writeText;
   inherit (depot.web) atom-feed blog tvl;
 
   listPosts = defun [ (list blog.post) string ] (posts:
@@ -16,7 +16,7 @@ let
       (map (p: "cp ${blog.renderPost tvl.blog.config p} $out/blog/${p.key}.html") posts)
   );
 
-  tvlGraph = runCommandNoCC "tvl.svg"
+  tvlGraph = runCommand "tvl.svg"
     {
       nativeBuildInputs = with pkgs; [ fontconfig freetype cairo jetbrains-mono ];
     } ''
@@ -63,6 +63,20 @@ let
       Feel free to explore the tech we have built so far, all our
       systems are linked in the footer.
 
+      ----------------
+
+      ## Blog
+
+      Here are the most recent TVL blog posts.
+
+      ${listPosts publishedPosts}
+
+      You can also follow our [atom feed](https://tvl.fyi/feed.atom).
+
+      ----------------
+
+      ## Getting in touch
+
       We mostly hang out on IRC. You can find us in [`#tvl`][tvl-irc]
       on [hackint][], which is also reachable [via XMPP][hackint-xmpp]
       at [`#tvl@irc.hackint.org`][tvl-xmpp] (sic!) and [via
@@ -78,15 +92,11 @@ let
       [tvl-matrix]: https://matrix.to/#/#tvl:hackint.org
       [tvl-webchat]: https://webirc.hackint.org/#ircs://irc.hackint.org/#tvl
 
-      ----------------
-
-      ## Blog
-
-      Here are the most recent TVL blog posts.
+      Discussions of our software, patches, and anything else really
+      can also be sent to us via email to **depot@tvl.su**. You can
+      see the mails submitted to that list in our [public inbox][].
 
-      ${listPosts publishedPosts}
-
-      You can also follow our [atom feed](https://tvl.fyi/feed.atom).
+      [public inbox]: https://inbox.tvl.su
 
       ----------------
 
@@ -123,7 +133,7 @@ let
     '';
   };
 in
-runCommandNoCC "website" { } ''
+runCommand "website" { } ''
   mkdir -p $out/blog
   cp ${homepage} $out/index.html
   ${postRenderingCommands tvl.blog.posts}