about summary refs log tree commit diff
path: root/web/homepage/nginx.nix
diff options
context:
space:
mode:
Diffstat (limited to 'web/homepage/nginx.nix')
-rw-r--r--web/homepage/nginx.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/web/homepage/nginx.nix b/web/homepage/nginx.nix
index 33b89ee7cc..011f48d51b 100644
--- a/web/homepage/nginx.nix
+++ b/web/homepage/nginx.nix
@@ -14,9 +14,9 @@ let
   inherit (pkgs.third_party) ;
 
   oldRedirects = lib.concatStringsSep "\n" (map (post: ''
-    location ~* ^(en)?/${post.oldKey} {
+    location ~* ^(/en)?/${post.oldKey} {
       # TODO(tazjin): 301 once this works
-      return 302 /${post.key};
+      return 302 /blog/${post.key};
     }
   '') (filter (hasAttr "oldKey") blog.posts));