about summary refs log tree commit diff
path: root/web/bubblegum/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'web/bubblegum/default.nix')
-rw-r--r--web/bubblegum/default.nix39
1 files changed, 22 insertions, 17 deletions
diff --git a/web/bubblegum/default.nix b/web/bubblegum/default.nix
index 528d73032b..ed9ab61680 100644
--- a/web/bubblegum/default.nix
+++ b/web/bubblegum/default.nix
@@ -10,23 +10,28 @@ let
     nint
     ;
 
-  minimalDepot = sparseTree depot.path.origSrc [
-    # general depot things
-    "default.nix"
-    "nix/readTree"
-    # nixpkgs for lib and packages
-    "third_party/nixpkgs"
-    "third_party/overlays"
-    # bubblegum and its dependencies
-    "web/bubblegum"
-    "nix/runExecline"
-    "nix/utils"
-    "nix/sparseTree"
-    # tvix docs for svg demo
-    "tvix/docs"
-    # for blog.nix
-    "users/sterni/nix"
-  ];
+  minimalDepot = sparseTree {
+    root = depot.path.origSrc;
+    name = "minimal-depot";
+
+    paths = [
+      # general depot things
+      "default.nix"
+      "nix/readTree"
+      # nixpkgs for lib and packages
+      "third_party/nixpkgs"
+      "third_party/overlays"
+      # bubblegum and its dependencies
+      "web/bubblegum"
+      "nix/runExecline"
+      "nix/utils"
+      "nix/sparseTree"
+      # tvix docs for svg demo
+      "tvix/docs"
+      # for blog.nix
+      "users/sterni/nix"
+    ];
+  };
 
   statusCodes = {
     # 1xx