about summary refs log tree commit diff
path: root/web/blog/fragments.nix
diff options
context:
space:
mode:
Diffstat (limited to 'web/blog/fragments.nix')
-rw-r--r--web/blog/fragments.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/web/blog/fragments.nix b/web/blog/fragments.nix
index b13ba20c66..18416e4c4d 100644
--- a/web/blog/fragments.nix
+++ b/web/blog/fragments.nix
@@ -6,11 +6,11 @@
 # fragments together in a runCommand execution.
 #
 # The post index is generated by //web/homepage, not by this code.
-{ pkgs, lib, ... }:
+{ depot, lib, ... }:
 
 let
   inherit (builtins) filter map hasAttr replaceStrings toFile;
-  inherit (pkgs.third_party) runCommandNoCC writeText;
+  inherit (depot.third_party) runCommandNoCC writeText;
 
   # Generate a post list for all listed, non-draft posts.
   isDraft = post: (hasAttr "draft" post) && post.draft;
@@ -86,7 +86,7 @@ let
     }
 
     # Write the actual post through cheddar's about-filter mechanism
-    cat ${post.content} | ${pkgs.tools.cheddar}/bin/cheddar --about-filter ${post.content} >> $out
+    cat ${post.content} | ${depot.tools.cheddar}/bin/cheddar --about-filter ${post.content} >> $out
     echo '</article>' >> $out
 
     cat ${toFile "footer.html" footer} >> $out