about summary refs log tree commit diff
path: root/views/kit/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'views/kit/default.nix')
-rw-r--r--views/kit/default.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/views/kit/default.nix b/views/kit/default.nix
new file mode 100644
index 0000000000..759b36997a
--- /dev/null
+++ b/views/kit/default.nix
@@ -0,0 +1,19 @@
+# Externally importable TVL depot stack. This is intended to be called
+# with a supplied package set, otherwise the package set currently in
+# use by the TVL depot will be used.
+#
+# For now, readTree is not used inside of this configuration to keep
+# it simple. Adding it may be useful if we set up test scaffolding
+# around the exported workspace.
+
+{ pkgs ? import ./nixpkgs { depotOverlays = false; }, ... }:
+
+pkgs.lib.fix(self: {
+  buildGo = import ./buildGo { inherit pkgs; };
+  buildkite = import ./buildkite { inherit pkgs; };
+  readTree = import ./readTree { };
+
+  besadii = import ./besadii {
+    depot.nix.buildGo = self.buildGo;
+  };
+})