about summary refs log tree commit diff
path: root/users/wpcarro/website/sandbox/learnpianochords/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/wpcarro/website/sandbox/learnpianochords/default.nix')
-rw-r--r--users/wpcarro/website/sandbox/learnpianochords/default.nix41
1 files changed, 22 insertions, 19 deletions
diff --git a/users/wpcarro/website/sandbox/learnpianochords/default.nix b/users/wpcarro/website/sandbox/learnpianochords/default.nix
index 934fbd70ac..7cfdf7c451 100644
--- a/users/wpcarro/website/sandbox/learnpianochords/default.nix
+++ b/users/wpcarro/website/sandbox/learnpianochords/default.nix
@@ -8,7 +8,7 @@ let
     , src
     , name
     , srcdir ? "./src"
-    , targets ? []
+    , targets ? [ ]
     , registryDat ? ./registry.dat
     , outputJavaScript ? false
     }:
@@ -24,33 +24,36 @@ let
         inherit registryDat;
       };
 
-      installPhase = let
-        elmfile = module: "${srcdir}/${builtins.replaceStrings ["."] ["/"] module}.elm";
-        extension = if outputJavaScript then "js" else "html";
-      in ''
-        mkdir -p $out/share/doc
-        ${lib.concatStrings (map (module: ''
-          echo "compiling ${elmfile module}"
-          elm make ${elmfile module} --output $out/${module}.${extension} --docs $out/share/doc/${module}.json
-          ${lib.optionalString outputJavaScript ''
-            echo "minifying ${elmfile module}"
-            uglifyjs $out/${module}.${extension} --compress 'pure_funcs="F2,F3,F4,F5,F6,F7,F8,F9,A2,A3,A4,A5,A6,A7,A8,A9",pure_getters,keep_fargs=false,unsafe_comps,unsafe' \
-                | uglifyjs --mangle --output $out/${module}.min.${extension}
-          ''}
-        '') targets)}
-      '';
+      installPhase =
+        let
+          elmfile = module: "${srcdir}/${builtins.replaceStrings ["."] ["/"] module}.elm";
+          extension = if outputJavaScript then "js" else "html";
+        in
+        ''
+          mkdir -p $out/share/doc
+          ${lib.concatStrings (map (module: ''
+            echo "compiling ${elmfile module}"
+            elm make ${elmfile module} --output $out/${module}.${extension} --docs $out/share/doc/${module}.json
+            ${lib.optionalString outputJavaScript ''
+              echo "minifying ${elmfile module}"
+              uglifyjs $out/${module}.${extension} --compress 'pure_funcs="F2,F3,F4,F5,F6,F7,F8,F9,A2,A3,A4,A5,A6,A7,A8,A9",pure_getters,keep_fargs=false,unsafe_comps,unsafe' \
+                  | uglifyjs --mangle --output $out/${module}.min.${extension}
+            ''}
+          '') targets)}
+        '';
     };
   mainDotElm = mkDerivation {
     name = "elm-app-0.1.0";
     srcs = ./elm-srcs.nix;
     src = builtins.path { path = ./.; name = "learnpianochords"; };
-    targets = ["Main"];
+    targets = [ "Main" ];
     srcdir = "./src";
     outputJavaScript = true;
   };
-in stdenv.mkDerivation {
+in
+stdenv.mkDerivation {
   name = "learn-piano-chords";
-  buildInputs = [];
+  buildInputs = [ ];
   src = builtins.path { path = ./.; name = "learnpianochords"; };
   buildPhase = ''
     mkdir -p $out