about summary refs log tree commit diff
path: root/users/wpcarro/utils/fs.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/wpcarro/utils/fs.nix')
-rw-r--r--users/wpcarro/utils/fs.nix9
1 files changed, 5 insertions, 4 deletions
diff --git a/users/wpcarro/utils/fs.nix b/users/wpcarro/utils/fs.nix
index 6305e705b1..d7d5e34e99 100644
--- a/users/wpcarro/utils/fs.nix
+++ b/users/wpcarro/utils/fs.nix
@@ -5,7 +5,8 @@
 let
   inherit (builtins) attrNames hasAttr map readDir;
   inherit (pkgs.lib) filterAttrs;
-in {
+in
+{
   # Returns a list of all of the regular files in `dir`.
   files = dir:
     map (name: dir + "/${name}")
@@ -31,11 +32,11 @@ in {
     if hasAttr name (readDir dir) then
       dir + "/${name}"
     else
-      # This prevents the function from infinitely recursing and eventually
-      # stack overflowing.
+    # This prevents the function from infinitely recursing and eventually
+    # stack overflowing.
       if (dirOf dir) == dir then
         null
       else
         resolve name (dirOf dir);
-  };
+};
 }