about summary refs log tree commit diff
path: root/users/wpcarro/nixos/marcus/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/wpcarro/nixos/marcus/default.nix')
-rw-r--r--users/wpcarro/nixos/marcus/default.nix41
1 files changed, 31 insertions, 10 deletions
diff --git a/users/wpcarro/nixos/marcus/default.nix b/users/wpcarro/nixos/marcus/default.nix
index fb4442c6cc..a97d6d264d 100644
--- a/users/wpcarro/nixos/marcus/default.nix
+++ b/users/wpcarro/nixos/marcus/default.nix
@@ -3,17 +3,23 @@
 
 let
   inherit (depot.users) wpcarro;
-  wpcarrosEmacs = wpcarro.emacs.nixos;
+  inherit (depot.users.wpcarro.lib) usermod;
+
+  wpcarrosEmacs = wpcarro.emacs.nixos {
+    load = [ ./marcus.el ];
+  };
 
   quasselClient = pkgs.quassel.override {
     client = true;
     enableDaemon = false;
     monolithic = false;
   };
-in {
+in
+{
   imports = [
-    (depot.path + "/users/wpcarro/nixos/marcus/hardware.nix")
-    "${pkgs.home-manager.src}/nixos"
+    (depot.path.origSrc + "/users/wpcarro/nixos/marcus/hardware.nix")
+    (pkgs.home-manager.src + "/nixos")
+    (usermod "laptop.nix")
   ];
 
   # Use the TVL binary cache
@@ -34,8 +40,16 @@ in {
   };
 
   services = wpcarro.common.services // {
+    # Enable the Tailscale daemon to connect to work and personal Tailnet.
+    tailscale.enable = true;
+
     tzupdate.enable = true;
 
+    depot.auto-deploy = {
+      enable = true;
+      interval = "1d";
+    };
+
     xserver = {
       enable = true;
       libinput = {
@@ -43,8 +57,8 @@ in {
         touchpad.naturalScrolling = false;
         touchpad.tapping = false;
       };
-      layout = "us";
-      xkbOptions = "caps:escape";
+      xkb.layout = "us";
+      xkb.options = "caps:escape";
       displayManager = {
         # Give EXWM permission to control the session (from tazjin's setup).
         sessionCommands = "${pkgs.xorg.xhost}/bin/xhost +SI:localhost:$USER";
@@ -82,7 +96,7 @@ in {
   security.sudo.wheelNeedsPassword = false;
 
   fonts = {
-    fonts = with pkgs; [
+    packages = with pkgs; [
       jetbrains-mono
     ];
 
@@ -93,9 +107,7 @@ in {
     };
   };
 
-  programs = wpcarro.common.programs // {
-    light.enable = true;
-  };
+  programs = wpcarro.common.programs;
 
   environment.variables = {
     EDITOR = "emacsclient";
@@ -120,6 +132,12 @@ in {
       backend = "glx";
     };
 
+    services.redshift = {
+      enable = true;
+      latitude = 37.4223931;
+      longitude = -122.0864016;
+    };
+
     services.dunst.enable = true;
     xdg.configFile."dunst/dunstrc" = {
       source = wpcarro.dotfiles.dunstrc;
@@ -129,6 +147,9 @@ in {
     };
 
     systemd.user.startServices = true;
+
+    # Previous default version, see https://github.com/nix-community/home-manager/blob/master/docs/release-notes/rl-2211.adoc
+    home.stateVersion = "18.09";
   };
 
   environment.systemPackages =