about summary refs log tree commit diff
path: root/users/wpcarro/nixos/marcus/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/wpcarro/nixos/marcus/default.nix')
-rw-r--r--users/wpcarro/nixos/marcus/default.nix15
1 files changed, 6 insertions, 9 deletions
diff --git a/users/wpcarro/nixos/marcus/default.nix b/users/wpcarro/nixos/marcus/default.nix
index a97d6d264de6..491c010ac871 100644
--- a/users/wpcarro/nixos/marcus/default.nix
+++ b/users/wpcarro/nixos/marcus/default.nix
@@ -50,13 +50,14 @@ in
       interval = "1d";
     };
 
+    libinput = {
+      enable = true;
+      touchpad.naturalScrolling = false;
+      touchpad.tapping = false;
+    };
+
     xserver = {
       enable = true;
-      libinput = {
-        enable = true;
-        touchpad.naturalScrolling = false;
-        touchpad.tapping = false;
-      };
       xkb.layout = "us";
       xkb.options = "caps:escape";
       displayManager = {
@@ -78,10 +79,6 @@ in
     };
   };
 
-  # Enable sound.
-  sound.enable = true;
-  hardware.pulseaudio.enable = true;
-
   users.mutableUsers = true;
   users.users.wpcarro = {
     isNormalUser = true;