about summary refs log tree commit diff
path: root/users/wpcarro/nixos/ava/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/wpcarro/nixos/ava/default.nix')
-rw-r--r--users/wpcarro/nixos/ava/default.nix26
1 files changed, 17 insertions, 9 deletions
diff --git a/users/wpcarro/nixos/ava/default.nix b/users/wpcarro/nixos/ava/default.nix
index ace2c81cfd..25c43c003f 100644
--- a/users/wpcarro/nixos/ava/default.nix
+++ b/users/wpcarro/nixos/ava/default.nix
@@ -55,10 +55,15 @@ in
 
     openssh.enable = true;
 
+    printing = {
+      enable = true;
+      drivers = with pkgs; [ gutenprint ];
+    };
+
     xserver = {
       enable = true;
-      layout = "us";
-      xkbOptions = "caps:escape";
+      xkb.layout = "us";
+      xkb.options = "caps:escape";
       displayManager = {
         # Give EXWM permission to control the session (from tazjin's setup).
         sessionCommands = "${pkgs.xorg.xhost}/bin/xhost +SI:localhost:$USER";
@@ -76,11 +81,13 @@ in
   hardware.pulseaudio.enable = true;
 
   users.mutableUsers = true;
-  users.users.root.openssh.authorizedKeys.keys = [
-    wpcarro.keys.nathan
-    wpcarro.keys.tarasco
+  users.users.root.openssh.authorizedKeys.keys = with wpcarro.keys; [
+    iphone
+    nathan
+    tarasco
   ];
   users.users.wpcarro = {
+    initialPassword = "password";
     isNormalUser = true;
     extraGroups = [
       "networkmanager"
@@ -88,9 +95,10 @@ in
       "docker"
     ];
     shell = pkgs.fish;
-    openssh.authorizedKeys.keys = [
-      wpcarro.keys.nathan
-      wpcarro.keys.tarasco
+    openssh.authorizedKeys.keys = with wpcarro.keys; [
+      iphone
+      nathan
+      tarasco
     ];
   };
   users.extraGroups.vboxusers.members = [ "wpcarro" ];
@@ -98,7 +106,7 @@ in
   security.sudo.wheelNeedsPassword = false;
 
   fonts = {
-    fonts = with pkgs; [
+    packages = with pkgs; [
       jetbrains-mono
     ];