about summary refs log tree commit diff
path: root/users/wpcarro/common.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/wpcarro/common.nix')
-rw-r--r--users/wpcarro/common.nix22
1 files changed, 15 insertions, 7 deletions
diff --git a/users/wpcarro/common.nix b/users/wpcarro/common.nix
index dcda9e10a4..582b63fc4c 100644
--- a/users/wpcarro/common.nix
+++ b/users/wpcarro/common.nix
@@ -29,7 +29,8 @@ in
     # Remodel the system clipboard as a list instead of a point.
     clipmenu.enable = true;
 
-    locate.enable = true;
+    # TODO(wpcarro): broken in nixpkgs as of 2023-10-04
+    locate.enable = false;
 
     depot.automatic-gc = {
       enable = true;
@@ -43,25 +44,23 @@ in
   # Command-line tools I commonly used and want available on most (or all) of my
   # machines.
   shell-utils = with pkgs; [
+    age
     bat
-    dig
+    coreutils
     direnv
     diskus
     emacs
-    exa
     fd
     fzf
     git
     gnupg
     htop
     jq
-    mkpasswd
     nmap
-    pass
+    passage
     python3
     rink
     ripgrep
-    sysz
     tldr
     tokei
     tree
@@ -71,5 +70,14 @@ in
     # wpcarro.tools.simple_vim
     xclip
     zip
-  ];
+  ] ++
+  (if pkgs.stdenv.isLinux then [
+    mkpasswd
+    sysz
+    # This depends on compiler-rt-libc-10.0.1, which is marked as broken on
+    # aarch64-darwin, but depot sets `allowBroken = true`, which means any
+    # build that depends on dig will fail on OSX (e.g. emacs).
+    # https://cs.tvl.fyi/github.com/NixOS/nixpkgs@e9b195248c6cd7961a453b10294aea9ab58e01b4/-/blob/pkgs/development/compilers/llvm/10/compiler-rt/default.nix?L122
+    dig
+  ] else [ ]);
 }