about summary refs log tree commit diff
path: root/users/wpcarro/ci/pipelines/post-receive.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/wpcarro/ci/pipelines/post-receive.nix')
-rw-r--r--users/wpcarro/ci/pipelines/post-receive.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/users/wpcarro/ci/pipelines/post-receive.nix b/users/wpcarro/ci/pipelines/post-receive.nix
new file mode 100644
index 0000000000..09b8990e13
--- /dev/null
+++ b/users/wpcarro/ci/pipelines/post-receive.nix
@@ -0,0 +1,14 @@
+{ pkgs, depot, ... }:
+
+let
+  inherit (builtins) path toJSON;
+
+  pipeline.steps = [
+    {
+      key = "lint-secrets";
+      command = "${pkgs.git-secrets}/bin/git-secrets --scan-history";
+      label = ":broom: lint secrets";
+    }
+  ];
+in
+pkgs.writeText "pipeline.yaml" (toJSON pipeline)