about summary refs log tree commit diff
path: root/users/tazjin/nixos/tverskoy/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/tazjin/nixos/tverskoy/default.nix')
-rw-r--r--users/tazjin/nixos/tverskoy/default.nix12
1 files changed, 3 insertions, 9 deletions
diff --git a/users/tazjin/nixos/tverskoy/default.nix b/users/tazjin/nixos/tverskoy/default.nix
index c2694bf5eb..48bd615049 100644
--- a/users/tazjin/nixos/tverskoy/default.nix
+++ b/users/tazjin/nixos/tverskoy/default.nix
@@ -1,12 +1,6 @@
 { depot, lib, pkgs, ... }:
 
 config: let
-  # add google-c-style here because other machines get it from, eh,
-  # elsewhere.
-  emacs = (depot.users.tazjin.emacs.overrideEmacs(epkgs: epkgs ++ [
-    pkgs.emacsPackages.google-c-style
-  ]));
-
   nixpkgs = import pkgs.path {
     config.allowUnfree = true;
   };
@@ -185,7 +179,7 @@ in lib.fix(self: {
 
       windowManager.session = lib.singleton {
         name = "exwm";
-        start = "${emacs}/bin/tazjins-emacs";
+        start = "${depot.users.tazjin.emacs}/bin/tazjins-emacs";
       };
     };
   };
@@ -220,10 +214,10 @@ in lib.fix(self: {
   environment.systemPackages =
     # programs from the depot
     (with depot; [
-      emacs
+      screenLock
       third_party.lieer
       tools.nsfv-setup
-      screenLock
+      users.tazjin.emacs
     ]) ++
 
     # programs from nixpkgs