about summary refs log tree commit diff
path: root/users/tazjin/nixos/modules/desktop.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/tazjin/nixos/modules/desktop.nix')
-rw-r--r--users/tazjin/nixos/modules/desktop.nix10
1 files changed, 6 insertions, 4 deletions
diff --git a/users/tazjin/nixos/modules/desktop.nix b/users/tazjin/nixos/modules/desktop.nix
index c78463386c..12a42b8faa 100644
--- a/users/tazjin/nixos/modules/desktop.nix
+++ b/users/tazjin/nixos/modules/desktop.nix
@@ -1,11 +1,12 @@
 # EXWM and other desktop configuration.
-{ depot, lib, pkgs, ... }:
+{ config, depot, lib, pkgs, ... }:
 
 {
   services = {
     pipewire = {
       enable = true;
       alsa.enable = true;
+      alsa.support32Bit = true;
       pulse.enable = true;
     };
 
@@ -14,8 +15,8 @@
 
     xserver = {
       enable = true;
-      layout = "us";
-      xkbOptions = "caps:super";
+      xkb.layout = "us";
+      xkb.options = "caps:super";
 
       libinput.enable = true;
 
@@ -28,7 +29,7 @@
 
       windowManager.session = lib.singleton {
         name = "exwm";
-        start = "${depot.users.tazjin.emacs}/bin/tazjins-emacs";
+        start = "${config.tazjin.emacs}/bin/tazjins-emacs --internal-border=0 --border-width=0";
       };
     };
   };
@@ -40,6 +41,7 @@
     QT_IM_MODULE = "xim";
     CLUTTER_IM_MODULE = "xim";
     EDITOR = "emacsclient";
+    _JAVA_AWT_WM_NONREPARENTING = "1";
   };
 
   # Do not restart the display manager automatically