about summary refs log tree commit diff
path: root/users/tazjin/nixos/koptevo/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/tazjin/nixos/koptevo/default.nix')
-rw-r--r--users/tazjin/nixos/koptevo/default.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/users/tazjin/nixos/koptevo/default.nix b/users/tazjin/nixos/koptevo/default.nix
index a3eede1c57..39a4887c72 100644
--- a/users/tazjin/nixos/koptevo/default.nix
+++ b/users/tazjin/nixos/koptevo/default.nix
@@ -147,11 +147,14 @@ in
   };
 
   # hack to work around the strict sandboxing of the gonic module
-  # breaking DNS resolutino
+  # breaking DNS resolution
   systemd.services.gonic.serviceConfig.BindReadOnlyPaths = [
     "-/etc/resolv.conf"
   ];
 
+  # add a hard dependency on the FUSE mount
+  systemd.services.gonic.requires = [ "geesefs.service" ];
+
   services.nginx.virtualHosts."music.tazj.in" = {
     addSSL = true;
     enableACME = true;