about summary refs log tree commit diff
path: root/users/tazjin/homepage/feed.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/tazjin/homepage/feed.nix')
-rw-r--r--users/tazjin/homepage/feed.nix23
1 files changed, 3 insertions, 20 deletions
diff --git a/users/tazjin/homepage/feed.nix b/users/tazjin/homepage/feed.nix
index 984b1c2950..2c6634e659 100644
--- a/users/tazjin/homepage/feed.nix
+++ b/users/tazjin/homepage/feed.nix
@@ -4,25 +4,11 @@
 with depot.nix.yants;
 
 let
-  inherit (builtins) map readFile sort foldl';
+  inherit (builtins) map readFile;
   inherit (lib) max singleton;
   inherit (pkgs) writeText;
-  inherit (depot.nix) renderMarkdown;
   inherit (depot.web) blog atom-feed;
 
-  postToEntry = defun [ blog.post atom-feed.entry ] (post: rec {
-    id = "https://tazj.in/blog/${post.key}";
-    title = post.title;
-    content = readFile (renderMarkdown post.content);
-    published = post.date;
-    updated = post.updated or post.date;
-
-    links = singleton {
-      rel = "alternate";
-      href = id;
-    };
-  });
-
   pageEntryToEntry = defun [ entry atom-feed.entry ] (e: {
     id = "tazjin:${e.class}:${toString e.date}";
     updated = e.date;
@@ -36,16 +22,13 @@ let
     };
   });
 
-  allEntries = (map postToEntry depot.users.tazjin.blog.posts)
+  allEntries = (map blog.toFeedEntry depot.users.tazjin.blog.posts)
              ++ (map pageEntryToEntry pageEntries);
 
-  mostRecentlyUpdated = foldl' max 0 (map (e: e.updated) allEntries);
-
   feed = {
     id = "https://tazj.in/";
     title = "tazjin's interblag";
     subtitle = "my posts, projects and other interesting things";
-    updated = mostRecentlyUpdated;
     rights = "© 2020 tazjin";
     authors = [ "tazjin" ];
 
@@ -54,6 +37,6 @@ let
       href = "https://tazjin/feed.atom";
     };
 
-    entries = sort (a: b: a.published > b.published) allEntries;
+    entries = allEntries;
   };
 in writeText "feed.atom" (atom-feed.renderFeed feed)